fribidi 缓冲区错误漏洞 安全响应中心

admin 28天前 72

漏洞简介

fribidi是一款Unicode双向算法的开源实现。

fribidi 1.0.0版本至1.0.7版本中的lib/fribidi-bidi.c文件的‘fribidi_get_par_embedding_levels_ex()’函数存在缓冲区错误漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,详情请关注厂商主页:

http://fribidi.org/

参考网址

来源:usn.ubuntu.com

链接:https://usn.ubuntu.com/4179-1/


来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/ESB-2019.4215/

受影响实体

    暂无


少客联盟- 版权声明 1、本主题所有言论和图片纯属会员个人意见,与少客联盟立场无关。
2、本站所有主题由该帖子作者发表,该帖子作者admin少客联盟享有帖子相关版权。
3、少客联盟管理员和版主有权不事先通知发贴者而删除本文。
4、其他单位或个人使用、转载或引用本文时必须同时征得该帖子作者admin少客联盟的同意。
5、帖子作者须承担一切因本文发表而直接或间接导致的民事或刑事法律责任。
6、本帖部分内容转载自其它媒体,但并不代表本站赞同其观点和对其真实性负责。
7、如本帖侵犯到任何版权问题,请立即告知本站,本站将及时予与删除并致以最深的歉意。
8、官方反馈邮箱:chinasuc@chinasuc.cn


上一篇:Valleylab FT10和Valleylab FX8 安全漏洞
下一篇:谷歌联合三家安全公司共同打击Android恶意软件
最新回复 (0)
全部楼主
    • 少客联盟
      2
        登录 注册 QQ登录(停用)
返回
负责声明:本站部分资源来源于网络,如有侵权请发邮件(chinasuc@chinasuc.cn)告知我们,我们将会在24小时内处理。